Pico Technology Automotive Application note

This application note was submitted by Arnot Franses (contact details at end). If you have an interesting application you wish to share with others, please get in touch.

Audi S2 (B3 Engine) Intermittent and progressive failure to start.

I doubt that anyone else will see this fault and it was interesting and challenging to track down. I hope that this description of what happened will be of interest rather than help for your sakes!

Initial symptoms

The car was brought to us on the back of a tow truck, the owner reported that after running faultlessly for some four months after a new distributor had been fitted, one morning, for no obvious reason, the car would not start. Some six months ago the top of the engine had been rebuilt as a result of damage caused by overheating. Other than that we have little history on the car. The owner seems sensible and is not the type to try to play with the car himself. As far as we can find out, all the information provided is true.

This car has a 2.3 litre (we think), 5 cylinder, 20-valve turbocharged engine with Bosch Motronic control with sequential injection and a relatively standard distributor. In standard form it develops about 275 bhp. The variation on the standard Bosch electronic distributor is that there is only one slot in the timing vane, which seems to vaguely align with number one cylinder.

Initial examination revealed that there was no ignition and no injector pulsing but the fuel pump relay was activated during cranking. I mention this because on this car the fuel pump supply also feeds part of the ignition circuit.

Diagnostic procedure

Firstly, the ECU fault codes were read and they showed a mix of RPM, TDC and Hall sender problems as well as a mechanical fault and a base set up fault. This didn't help too much! So to start the ball rolling, we checked the mechanical position of the distributor (in case it had slipped since we fitted it) and it was where we left it (which was where the original was). Then we measured the output levels of the TDC and RPM sensors and found that the TDC sensor output was only about half what it should be. The RPM sensor was OK and the Hall sender in the distributor seemed OK.

It then took ten days to get hold of the relevant new TDC sensor but finally it came, was installed and it wouldn't start! Just the same as before, no ignition, no injection. Checking the ECU fault codes showed another bundle of sensor and mechanical problems but with no obvious pattern. At this stage we thought "what if there is no fault code for a damaged ECU?" So we stripped it down and checked it as far as we could but found no problems. We are fortunate to have more customers with these Audi's so we took the ECU from this car and tried it on a known good car and it fired up first time and ran perfectly.

So, we started to get clever, we used a ADC212 PC based scope to check the outputs from the TDC and RPM sensors and the waveform on the Hall effect switch in the distributor. The RPM trace seemed to be what we would expect, the Hall trace looked OK but the RPM was all over the place, we were getting pulses but as seen below, they really didn't make sense. See the trace below. (Red is Hall effect switch and blue is the TDC sensor both read at the ECU.)

So, at this point we thought maybe we got sent a faulty sensor and tried the old one in. Apart from being a little lower, it wasn't really all that different.

It is little known that the TDC and RPM senders on these cars are in fact the same, the difference in part number indicates the colour of the harness plug. So, to be sure of the sensors, we tried all three (two old, one new) in each of the TDC and RPM positions. From this test, all three behaved acceptably in the RPM position and as shown above in the TDC position. It seemed difficult to imagine but it has been known for the TDC pin in the flywheel to fall out and rattle round the bell housing so we checked it manually (not so easy on these cars) and found no obvious fault.

After checking for the existence of the TDC peg, so that we could rule out mechanical problems, we removed the cam cover and checked the positions and synchronization of the crankshaft, pistons, exhaust and inlet camshafts and the distributor. No obvious faults here. Maybe the earths and supplies to the ECU were not all present? Well we had four illustrations that claimed to be for this car and they were all different in minor respects but other than that uncertainty, all seemed OK.

Then we noticed something strange, on two consecutive tests of the TDC sensor we got differing results! Not only that but there were some minor oddities on the Hall signal in that the width of the negative pulse varied from revolution to revolution slightly. Further examination revealed A faulty scope probe. At this stage words didn't exactly fail me but most of them won't spell check. Anyway, we replaced the faulty probe. Then we started to get interesting (if unusual) results. Not only that but the engine started, just once, and ran for a few seconds perfectly. After that, it went back to sulk mode and refused to play again. However, this did demonstrate that there was nothing serious wrong and that the testing we had done so far had yielded accurate results. After scratching our heads for a couple of days we realised that occasionally it would start and once running stayed that way, it was just unlikely to re start if then stopped.

Once we got it running and we started to do detailed dual trace measurements that we noticed that there was some flutter in the relationship between the Hall sender and the TDC sender - 2.65 degrees in fact. The next two illustrations show traces near to the extent of the variation. Both are taken as triggered 20ms before the fall of the Hall signal on a single test sequence.

As you can see, there is quite a spread!

What we noticed then was that if the engine stopped cranking with the fall of the Hall signal in line with the zero crossing of the TDC pulse, the engine would start and run. This then lead to the theory that it would only start if the zero crossing was within the negative pulse from the Hall switch. Whereas in the past, we thought that lining the two up as on the second trace was correct. To test this, we then loosened the distributor and tried the following two settings;

From this

To this!

Both of these allowed the engine to start but not reliably as the flutter in the distributor drive train meant that the start position was not always with the zero crossing inside the Hall pulse. Any further either way prevented it from starting completely.

Eventually we came to the conclusion that the Hall negative pulse acts as a "gate" during the start sequence and only allows the ECU to act on the TDC information when the zero crossing occurs when it is low. Testing has revealed that this is very critical and that if the distributor backlash range is as much as 0.1 of a millisecond outside the Hall pulse it won't start reliably.

Given that this theory was correct, we then set the distributor to the following trace

The engine now started perfectly!

However, when we road tested it, the car ran for about 5 minutes and then cut out. Having recovered it the Hall/TDC trace looked like this;

Obviously at this stage, the car would not run, however we would not have expected it to stop whilst running! From this it appeared that the distributor must have moved (as the TDC signal was governed by the fixed pin in the flywheel). However, when the valve cover and timing belt cover were removed, there was no fault found! The cam belt was tight enough, the cam chain allignment marks lined up at TDC, the cam chain was faultless, the distributor was faultless (it was only four month old!). In short we could find no reason for the movement.

Looking at the timing, it seems that the Hall effect switch interval is about 23 camshaft degrees (46 crankshaft degrees) and form this the movement must have been about 17 camshaft degrees (34 crankshaft degrees).

One thing we have noted is that there are two allignment marks on the distributor. When these are alligned, the Hall effect switch does not seem to be in line with the slot on the rotor. Also when the engine is set at TDC and the distributor adjusted so that the TDC pulse alligns with the centre of the Hall effect gate, these marks are nowhere near alligned.

Regardless of what information we have had, the Hall sender seems to be used to provide a safety gate for starting the engine and establishing which of the number one cylinder flywheel pulses is for compression/firing . Above cranking speed, the Hall sender seems to have little bearing on the running of the engine. In fact, once it is running it can be disconnected without any evident problems. It does seem though that if the distributor is moved while the engine is running so that the TDC pulse falls outside the Hall effect gate then the engine will stop. Given that after a few (50,000+) miles there is bound to be some distributor drive backlash, in future we should set the relationship to the above trace. It would seem that the original fault we had might have been as a result of this increasing distributor drive wear reaching a critical stage.

At some stage when we were reading the fault codes, we were getting Hall effect shorted to positive, mechanical fault and incorrect base setting, sometimes individually and sometimes in combination. It would seem that the relationship between the Hall and TDC signals is used by the ECU to calculate fault conditions and in our "on the edge" position, the error codes were misleading.

Where we went wrong!

We made an assumption! When will we ever learn?

Since at this stage there seemed to be nothing wrong with the engine or the electronics, we decided to go right back to the start and check absolutely everything and this is where we found the original fault, what had happened and fixed it (YIPPEE!). One piece of information I had left out and initially considered irrelevant, was that there are two TDC marks on this engine. One is a mark on the front pulley or vibration damper and the other is stamped on the periphery of the flywheel and viewed through an aperture in the bell housing (flywheel/clutch housing). Since the second mark is;

i) only lightly stamped

ii) tends to get rusted up with time

iii) almost impossible to see with all the hoses and cables lying around

and knowing that it was bolted to the crankshaft along with the front pulley, I ignored it - BIG MISTAKE! Obviously the flywheel could not have moved without either taking the engine out or some horrendous noises when the engine was running due to six or eight loose bolts rattling round, neither of which had occurred. But - when I carefully polished the periphery of the flywheel, found the timing mark and lined it up with the bottom of the viewing aperture, the front pulley mark did NOT line up!

At this stage, I used a dial test indicator to establish exactly when number one cylinder was at TDC and verified the flywheel timing mark was correct (there is no locating dowel on the flywheel of these engines so it can be fitted incorrectly!). Since it was, then it followed that the front pulley was incorrect and this was the one we had been using as a reference mark all along!

So I stripped down the front of the engine and removed the front pulley. It is important to note here that the securing bolt was VERY tight! It took a four-foot bar to crack it! When removed, all became obvious. The bottom cambelt sprocket attaches to the front pulley and has a locating peg cast as part of it that then locates into a slot on the front crankshaft boss. This in turn is a taper fit.

What had happened was that the locating peg had sheared and dissolved at some time in the past and rather than repairing it, some joker had merely tightened the pulley up almost to breaking point. This however had not been sufficient to prevent it moving slightly and occasionally as the car was driven. The actual amount of movement was restricted by what remained of the locating peg having worn a wide slot in the sprocket and damaged the front of the crankshaft.

The eventual fix was to replace the bottom cambelt sprocket with a new one, replace the front pulley that had been damaged by a combination of broken bits and movement and repair the front boss of the crankshaft. The crankshaft repair was carried out very carefully in-situ which was not ideal but removing and stripping the engine to do this would have been prohibitively expensive.

Once built up and set up, the car started and ran perfectly and as of now (17th August 1999) it has run perfectly for five weeks and the owner reports that it has never performed as well. Looking back at the iATN archives, I have notice a number of mysterious non starts of this type of engine in a number of Audi's, no-one else seems to have reported this finding but many have noted that resetting the distributor has cured the problem. I suspect that this is a generic problem which Audi are either unaware of or are keeping very quiet about.

I suspect that this car has been on the verge of stopping for months now. When we first saw it and changed the distributor, the owner brought it to us for an intermittent non-start fault. At the time we only got it to fail to start once in a whole week of testing and the fault code was faulty hall effect switch. Since this is not available as a separate item, the distributor was changed and this seemed to cure it. I now suspect that the very slight difference in distributor position and tighter bearings was what did the trick. Interestingly, given the actual fault, the valve timing must have been out of adjustment for all this time as well but without giving any obvious symptoms. It is a credit to the Motronic system that it can keep an engine running as well as this one did when it is so far out of adjustment.

If you would like (or need) any more information please e-mail me, Arnot Franses, on arnot_franses@compuserve.com .


DrDAQ data logger Pico Technology Company Information Ordering Information Technical support Download oscilloscope and data acquisition software Latest news about oscilloscopes and data loggers Data Acquisition Oscilloscopes and spectrum analyzers Pico Technology Home Page oscilloscopes and data loggers